トマシープが学ぶ

Mac/Unity/AR好きのミーハー初心者 記事内容は自分用のメモ。何も求めないで

pycharmにライブラリをインストールしたらエラーが出た。

PycharmのPreferenceのProject:>Project Interpreterからパッケージを入れることができます。

下の+ボタンを押して追加するのですが、エラーが出て、+ボタンを選択できませんでした。

f:id:bibinbaleo:20170502215246p:plain(画像は解決後)

解決方法としては、上の方にあるバージョン選択を2.6から2.7にしたら選択できました。

f:id:bibinbaleo:20170502215302p:plain

その後pipとnumpyは無事インストールできたのですが、matplotlibを同じくインストールしようとしたら、またエラーが出ました。

解決方法としては、エラー画面の一番上に出てた「pip~」をターミナルで打ってインストールした後、pycharmからも再びインストールしたら今度は無事できました。

よくわかってないけど多分これでいいはず。

その後、こんな感じで関数を使ってグラフを描画するコードを書いたら、

f:id:bibinbaleo:20170502215630p:plain

少し経ってからちゃんと描画されました。

f:id:bibinbaleo:20170502215737p:plain